26th April 2018

[RESOLVED]Multiple servers not accessible

Multiple servers in our USA facility are currently experiencing a service interruption. Users hosted on those servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE: 3:45 AM Eastern: Our team members are still looking into this.

UPDATE: 4:00 AM Eastern: The issue has been resolved and servers are back online.