3rd September 2021

[RESOLVED] Support ticket system interruption

Support Tickets in the A2 Hosting Client area are currently experiencing a service interruption. Users may have difficulties submitting Support tickets. Our development team is investigating the root cause of this interruption.

If you need our assistance, please, send an email to support@a2hosting.com, start a Live Chat or give us a call.

Contact information may be found on this page:  https://www.a2hosting.com/contact 

We will provide updates as more details are made available.

Update  - 02:10 AM EDT: Our Developers were able to identify and fix the problem. Customers should be able to submit tickets via the Client Area at A2 Hosting again.

If you experience any issues with the service, please do not hesitate to contact our live support for assistance.