1st September 2021

[COMPLETED] Scheduled Maintenance - SG Data Center

Start Date: Wednesday, Sept 1, 2021 EST (Thursday, Sept 2, 2021 SGT)

End Date: Wednesday, Sept 1, 2021 EST (Thursday, Sept 2 2021 SGT)

Time: 12:00 PM - 4:00 PM EST (12:00 AM - 4:00 AM SGT)

Services Affected:

Singapore Data Center

Description: Our System Operations team will be performing scheduled maintenance in our Singapore Datacenter. Users may experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 4:00PM: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.