15th July 2021

[COMPLETED] Arizona :: Scheduled Maintenance

Start Date: Friday, July 16, 2021

End Date: Friday, July 16, 2021

Time Start: 3:00 AM ET

Time End: 3:15 AM ET

Services: Arizona Data Center

Description: Our Network Engineering team will be performing scheduled maintenance on the Arizona Network. Users may experience brief service interruptions while the routine scheduled maintenance is performed.

UPDATE: maintenance completed at 3:15 AM.