9th June 2021

[RESOLVED] Managed WordPress SSL Issues

Our Managed WordPress Platform is currently experiencing issues with the server's SSL certificate. Users hosted on this server will experience service SSL errors as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 9:40 AM EDT: The issue has been resolved. If you continue to experience any issues with the service, please do not hesitate to contact us via ticket for assistance.