2nd June 2021

[RESOLVED] mi3-ss30 :: Service Interruption

mi3-ss30 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:00PM EDT: Our Engineers are still working on the issue. We will post updates as more information becomes available.

UPDATE 7:45PM EDT: Issues on mi3-ss30 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.