4th May 2021

[COMPLETED] Singapore DC Maintenance

Scheduled Maintenance - Singapore Data Center

Maintenance Window from 1-4 AM SGT 2021-05-05 (12-4 PM EDT 2021-05-04)

Services Affected: Singapore Data Center

Description: Our Network Engineering team will be performing scheduled maintenance in the Data Center. Users may experience brief service interruptions while the maintenance is performed.

UPDATE 12:10 PM EDT: Our Network Engineering team has started the scheduled maintenance. We will provide further updates as they're made available.

UPDATE 3:53 PM EDT: Our Network Engineering team is still working on the scheduled maintenance. We will provide further updates as they're made available.

UPDATE 6:40 PM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.