7th April 2021

[RESOLVED]Multiple Servers :: Intermittent Connectivity Issues

Our System Operations team is currently investigating reports of intermittent website & email connectivity issues affecting a subset of customers in our Michigan data center. We will provide updates as more details are made available.

UPDATE 1:53 PM EDT: Our System Operations team confirmed website & email connectivity is fully restored. If you continue to experience issues please contact our support team directly.