7th April 2021

[RESOLVED]ssr20 :: Service Interruption

ssr20.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 2:35AM EDT: Our Systems Operations team has corrected the issue and all services should be back online at this time.