17th February 2021

[RESOLVED] Control panel :: Interruption

Some servers in our fleet are currently facing a cPanel issue. Users hosted on this server will experience issues logging into cPanel via client area as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:25PM EST: Reported issues have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.