23rd January 2021

NL DC :: Scheduled Maintenance

Start Date: Saturday, January 23, 2021

End Date: Saturday, January 23, 2021

Time: 2:00 AM - 5:00 AM CEST (7:00 PM - 10:00 PM EST)

Services Affected: Our System Operations team will be performing routine scheduled maintenance in our Netherlands datacenter. Users may experience multiple momentary network interruptions while the routine scheduled maintenance is performed. 

Update 7:05 PM: The maintenance has now started.

Update 10:15PM: The maintenance in our Netherlands datacenter has been completed. Please reach out to our support team should you experience any further issues.