18th January 2021

[RESOLVED]Michigan DC :: Scheduled Maintenance

Start Date: Monday, Jan 18th 2021

End Date: Tuesday, Jan 19th 2021

Time: 11:00 PM - 12:00 AM EST

Services Affected: Our System Operations team will be performing routine scheduled maintenance in our Michigan datacenter. Users may experience multiple momentary network interruptions while the routine scheduled maintenance is performed. 

UPDATE 11:00PM EST: Our Data Center Engineers have started the maintenance. We will post updates as we receive more information in this regard.

UPDATE 1:40AM EST: Our Engineers have completed the maintenance for the datacenter at this time.