6th January 2021

[RESOLVED] Singapore DC :: Multiple Server Interruption

Multiple servers in our Singapore facility are currently experiencing service interruptions. Users hosted on the affected servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:50 PM EST: Our System Operations team has resolved this matter and all services are back online at this time.