5th January 2021

[RESOLVED] Live Chat :: Service Interruption

Our Live Chat application is currently facing issues. Clients contacting us via Live Chat may experience service degradation and disconnections as a result. We are investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 6:35PM EST: Issues with Live Chat Software have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.