23rd March 2018

[RESOLVED] A2S75 :: Service Interruption

A2S75 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 03/23/2018 20:30 EDT: We are glad to report that A2S75 is back online.