31st July 2020

[RESOLVED] SSDMAN25 :: Scheduled Maintenance

Start Date: Friday, July 31, 2020

End Date: Friday, July 31, 2020

Time: 9:00 PM - 11:00 PAM MST (11:59PM - 2:00 AM EST)

Services Affected:

SSDMAN25

Description: Our System Operations team will be performing scheduled maintenance on the server. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE: This maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.