20th March 2018

[RESOLVED] ssr15.supercp.com Service Interrup

ssr15.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 8:52PM Eastern:: Our Engineers have restored services and services are now working as expected.