24th July 2020

[RESOLVED]mi3-ls2 :: Service Interruption

mi3-ls2.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:00 AM EST: Our System Operations team has resolved this issue and all services are online at this time.