21st July 2020

Arizona DC :: Connectivity Issues

Our Arizona data center is currently experiencing connectivity issues. Users hosted in this data center will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 4:35PM EDT: Some of the impacted clients should see their sites responding at this time. Our Engineers are still working on the remaining servers currently impacted. We sincerely apologize for any inconvenience and appreciate your continued patience and understanding in this regard.

UPDATE 5:50PM EDT: All servers are currently back up and responding fine. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.