4th July 2020

[RESOLVED]mi3-wsr1 :: Service Interruption

mi3-wsr1 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 2:00AM - Our System Operations team has resolved this matter and all services are back online. If you continue to experience issues please contact our support team directly for further assistance