24th June 2020

[COMPLETED] mi3-ss33 :: Maintenance

Our Operations team is performing some emergency maintenance on the server mi3-ss33. This maintenance is aimed at improving server stability. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 11:35PM EDT: Maintenance has been completed on mi3-ss33. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.