8th March 2018

[RESOLVED]MI3-WSS6 :: Interruption

MI3-WSS6 is currently experiencing an interruption. Users will experience service degradation as a result.

UPDATE 18:50 EST: MI3-WSS6 is back online and working normally.