18th June 2020

[RESOLVED] Phone Service Interruption

Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a ticket while our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 4:08 PM: Issues with phones have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live chat support or open a ticket for assistance.