14th June 2020

[RESOLVED] MI3-WSS9 :: Service Interruption

MI3-WSS9 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 12:34 PM EDT: Issues on mi3-wss9 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.