13th June 2020

[RESOLVED] ssdsemi11 :: Service Interruption

ssdsemi11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 8:28 AM EST: Service on ssdemi11 has been fully restored. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.