7th June 2020

[RESOLVED] Phone Support Interruption

Start Date: Saturday, June 6, 2020

End Date: Saturday, June 6, 2020

Time: 12:00 AM - 02:00 AM EST

Services Affected:

A2 Phone Support

Description: Our System Operations team will be performing scheduled maintenance on our phone system. Customers calling our helpline may not be able to connect or may experience service degradation as a result. 

UPDATE 12:00AM: The maintenance has begun at this time. Further updates will be provided as they become available. 

UPDATE 1:30AM: The maintenance has been complete at this time. Our helpline is once again available.