1st March 2018

[RESOLVED] AZ1-SS1 :: Service Interruption

AZ1-SS1 is currently experiencing an interruption. Users will experience service degradation as a result.

UPDATE 5:00PM EST: We are glad to report that AZ1-SS1 is back online.