12th May 2020

[RESOLVED]my.a2hosting.com :: Service Interruption

Our customer portal, my.a2hosting.com is currently experiencing a service interruption. Users attempting to access https://my.a2hosting.com will experience a 504 error as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 12:25 PM EST: Our System Operations team is still working toward recovering access to our customer portal. We will continue to provide updates as they're made available.

UPDATE 1:35 PM EST: Our System Operations team has resolved this matter and our customer portal is back online.