11th May 2020

[RESOLVED] Network Connectivity

We are is currently receiving reports of intermittent network connectivity issues. At this time, our System Operations team is investigating. We will provide updates as more details are made available. We sincerely appreciate your cooperation and understanding while we resolve this issue.

UPDATE 11:00 PM EDT: Our Engineers are still working on it. We will post updates as more information becomes available.

UPDATE 10:10 AM EDT:  Our Network Engineers have resolved the intermittent connectivity issue. We apologize for the inconvenience.