11th May 2020

[RESOLVED] my.a2hosting.com Scheduled Maintenance, scheduled 1 month ago

Our billing system will be down for scheduled maintenance from 6am-8am Eastern Standard Time. This maintenance will not have an impact Client websites/servers.

UPDATE As of 8:20AM EDT: We have now completed this maintenance and you can already now login to your customer area.