1st May 2020

[RESOLVED]mi3-wts7 :: Reboot Required

mi3-wts7.a2hosting.com is currently being rebooted to correct an issue on the server. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 2:45 PM EST: Our System Operations team has performed the reboot and all services are back online.