30th April 2020

[RESOLVED]mi3-wss9 :: Service Interruption

mi3-wss9 is currently experiencing an interruption. Users hosted on this server may experience errors as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:55 AM EST: Our System Operations team has resolved this matter. We will continue to monitor this situation closely.