24th April 2020

[RESOLVED] - Website :: Customer Portal

A2Hosting.com & our customer portal my.a2hosting.com are currently experiencing a service interruption. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 9:16 AM EST: Our System Operations team has resolved this matter and both A2Hosting.com and our customer portal at my.a2hosting.com are back online at this time.