20th February 2018

[RESOLVED]Customer Area Maintenance

We are starting a Maintenance of the Customer Area at 6AM EST. Customers will not be able to access their accounts during this maintenance. The maintenance will not affect any other service or cause any downtime.

UPDATE 07:20 AM EST: The maintenance has been finished and the customer area is fully functional now