19th April 2020

mi3-wts1 :: Service Interruption

mi3-wts1.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 7:00AM EST: Our System Operations team is continuing their efforts to resolve all issues on the server. Further updates will be provided as they become available.

Update 8:57AM EST: Our System Operations team has now resolved this issue and the server is now back online.