19th February 2018

a2ss52.a2hosting.com :: Mail interruption

a2ss52.a2hosting.com is currently experiencing an interruption of incoming mail. Users will experience issues receiving incoming email.

Update :: 8:35PM EST :: We are continuing to work on the issue and will post updates as they become available.

Update :: 9:45PM EST :: Mail is now working on the server.  We will continue to monitor for any further issues.