9th April 2020

[RESOLVED] mi3-wss11 :: Service Interruption

mi3-wss11 is currently experiencing a service interruption. Our System Operations team is investigating this. We will provide updates as more details are made available.

UPDATED 3:45 AM EST: Our System Operations team has resolved this matter and all services are online at this time.