8th April 2020

[RESOLVED] mi3-wss11 :: Service Interruption

mi3-wss11 is currently experiencing a service interruption. Our System Operations team is investigating this. We will provide updates as more details are made available.

UPDATE 8:46 PM EST: Our Systems Operation team is still working on this. More Updates will be provided as they become available. 

UPDATED 12:03 AM EST: Our System Operations team has resolved this matter and all services are online at this time.