3rd April 2020

[RESOLVED]mi3-wts1 :: Reboot Required

mi3-wts1.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 1:57 PM EST: Our System Operations team has resolved this matter and all services are back online.