19th March 2020

mi3-ss14 :: Scheduled Maintenance

Start Date: Friday, March 20, 2020

End Date: Friday, March 20, 2020

Time: 1:00 AM - 2:00 AM EST (12:00 AM - 1:00 AM UTC)

Services Affected: mi3-ss14.a2hosting.com

Description: Our System Operations team will be performing routine emergency maintenance. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 1:40 AM EDT: Our System Operations Team has started working on this. We will post updates as more information is made available.

UPDATE 1:45 AM EDT:  This maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.