6th March 2020

[RESOLVED] mi3-wss11 :: Service Interruption

mi3-wss11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available

Update March 6, 2020, 5:57AM: Our System Operations team has corrected the issue affecting mi3-wss11. All services are available once again.