5th March 2020

[RESOLVED]mi3-wts7 :: Service Interruption

mi3-wts7 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 9:20 AM EST: Our System Operations team continues to work toward restoring Plesk services. All websites should be online at this time. We will continue to provide updates as they're made available.

UPDATE 11:02 AM EST: Our System Operations team continues to work toward restoring Plesk services. We will continue to provide updates as they're made available.

UPDATE 12:11 PM EST: Our System Operations team has restored Plesk services and all services are back online at this time.