3rd March 2020

mi3-wss11 :: Service Interruption

mi3-wss11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:55 PM EST: Our System Operations team continues to work on restoring all services. We will continue to provide updates as they're made available.

Update 4 March 2020 12:25AM: Our System Operations team has corrected the issue affecting mi3-wss11. All services are available once again.