28th February 2020

[RESOLVED] mi3-wss7 :: Service Interruption

mi3-wss7 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 6:08AM: mi3-wss11 is available. We do not expect any further issues, but we will continue to monitor the service for any trouble.