2nd February 2020

[RESOLVED] mi3-ss35 :: Service Interruption

mi2-ss35 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Updated: 02/02/20 3:51 PM Resolved: Our System Operations team has resolved this matter and all services are back online.