28th January 2020

[RESOLVED]mi3-wts10 :: Service Interruption

mi3-wts10.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 3:15AM EST: Our System Operations team has managed to resolve the issues at this time. We'll continue to monitor the server for any issues.