27th January 2020

[RESOLVED]mi3-wss7 :: Service Interruption

mi3-wss7.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 5:45AM EST: Our System Operations team was able to correct the issue and the service is once again available.