13th February 2018

[RESOLVED]A2S78 :: Service Interruption

A2S78 is currently experiencing a service interruption. Customers will experience service degredation as a result.

UPDATE 23:00 EST: Engineers are still working to restore service to A2S78. We appreciate your patience.

The server is back online and we are monitoring it for any new issues.