11th February 2018

wwwss12.a2hosting.com :: Service Interruption

wwwss12.a2hosting.com is currently experiencing an interruption in service. Users will experience service degradation as a result.

Update :: 3:45PM EST :: Our Engineers are still working on restoring service. We will be providing updates as quickly as possible.

Update :: 4:13PM EST :: Server has been brought back up. Please feel free to reach out to our live support if you continue to encounter any issues.