5th February 2018

mi3-ss4.a2hosting.com :: Plesk Interruption

mi3-wss4.a2hosting.com is currently experiencing an interruption in Plesk services. Users will experience service degradation as a result.

Update :: 1:25PM EST :: Plesk Services should now be stable when logging directly into Plesk. Our Engineers are further investigating issues with accessing Plesk through our Client Area.

Update :: 3:15PM EST :: Plesk Services should now be stable when logging into Plesk directly or through our Client Area.